Тема: Помогите настроить CISCO SOHO 97

Друзья, требуется помощь в освоении данной киски. Ни разу не работал с ними, а тут коллеги подарили. На зарубежных мануалах вычитал что у нее есть веб морда, но зайти никак не могу. Спаял консольный шнур, через терминал подключился к ней. Нашел пару доступных для меня мануалов по базовой настройке, но и тут то не так все просто. При настройке интерфейсов (присвоении IP) начинает ругаться на ошибку синтаксиса, а причину понять не могу. Есть спецы по первоначальной настройке таких цисок?

2

Re: Помогите настроить CISCO SOHO 97

давайте конкретные вопросы. Настраиваете интерфейс и выдает ошибку, покажите нам ее.

Добавлено: 27-08-2013 19:14:40

а у вас адсл интернет?

3

Re: Помогите настроить CISCO SOHO 97

crash пишет:

давайте конкретные вопросы. Настраиваете интерфейс и выдает ошибку, покажите нам ее.

Добавлено: 27-08-2013 19:14:40

а у вас адсл интернет?

У меня не адсл. Но ставить буду в другом месте. Сейчас для меня важно включить веб интерфейс. Вот как я делал:
сбросил командой # erase startup-config
# reload
после вот:
System Bootstrap, Version 12.2(11r)YV3, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 2004 by cisco Systems, Inc.
C800/SOHO series (Board ID: 22-128) platform with 65536 Kbytes of main memory

program load complete, entry point: 0x80013000, size: 0x5e9e4c
Self decompressing the image : ########################################################################################################## [OK]

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706



Cisco IOS Software, SOHO97 Software (SOHO97-K9OY1-M), Version 12.3(8)YG3, RELEASE SOFTWARE (fc1)
Synched to technology version 12.3(10.3)T2
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Tue 20-Sep-05 04:55 by ealyon
Image text-base: 0x800131D0, data-base: 0x80AFE04C


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco SOHO97 (MPC857DSL) processor (revision 0x500) with 58983K/6553K bytes of memory.
Processor board ID FCZ100814VT (3318797041), with hardware revision 401D
CPU rev number 7
1 Ethernet interface
1 ATM interface
128K bytes of NVRAM.
8192K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)


         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: noQ
% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? [yes/no]: no


Press RETURN to get started!


*Mar  1 00:00:12.451: %SYS-6-LOGGERSTART: Logger process started
*Mar  1 00:00:12.655: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
*Mar  1 00:00:14.143: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up
*Mar  1 00:00:14.655: %LINK-3-UPDOWN: Interface ATM0, changed state to down
*Mar  1 00:00:15.655: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to down
*Mar  1 00:00:16.147: %LINK-3-UPDOWN: Interface Ethernet0, changed state to down
*Mar  1 00:00:17.147: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to down
*Mar  1 00:37:49.387: %SYS-5-RESTART: System restarted --
Cisco IOS Software, SOHO97 Software (SOHO97-K9OY1-M), Version 12.3(8)YG3, RELEASE SOFTWARE (fc1)
Synched to technology version 12.3(10.3)T2
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Tue 20-Sep-05 04:55 by ealyon
*Mar  1 00:37:49.387: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing a cold start
*Mar  1 00:37:51.115: %LINK-5-CHANGED: Interface Ethernet0, changed state to administratively down
*Mar  1 00:37:51.115: %LINK-5-CHANGED: Interface ATM0, changed state to administratively down
Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface vlan1
                          ^
% Invalid input detected at '^' marker.

Router(config)#
Видно что неправильно обозвал имя интерфейса. Вопрос как поссмотреть? В Юниксе это ifconfig, а тут как?

4

Re: Помогите настроить CISCO SOHO 97

sh run 

покажите

Добавлено: 27-08-2013 19:49:41

имя интерфейса Ethernet0, а не vlan 1

5 (27-08-2013 16:57:10 отредактировано vershkov_v)

Re: Помогите настроить CISCO SOHO 97

crash пишет:
sh run 

покажите

Добавлено: 27-08-2013 19:49:41

имя интерфейса Ethernet0, а не vlan 1

А разве Ethernet0 это не интрефейс адсл? Вот вывод команды:

Router#sh run
Building configuration...

Current configuration : 618 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
!
!
no aaa new-model
!
!
!
!
!
!
!
interface Ethernet0
 no ip address
 shutdown
 hold-queue 100 out
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
 dsl operating-mode auto
!
ip classless
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
line con 0
 no modem enable
 transport preferred all
 transport output all
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end

6

Re: Помогите настроить CISCO SOHO 97

ADSL - это ATM0
сделайте

conf t
int eth0
no sh 
ip addr 192.168.0.1 255.255.255.0
exit
ip http server
exit
wr mem

Адрес на интерфейсе можете конечно указать свой.
Ну и заходить по http. Но если здесь веб интерфейс как на взрослых цисках, то ну его нафиг  smile

Добавлено: 27-08-2013 20:02:35

ах да, еще надо

conf t
username name password password
enable password password
line vty 0 4
login local

7

Re: Помогите настроить CISCO SOHO 97

блин, вроде все получилось пытаюсь зайти на морду сначала выбрал язык и висит на Loading Cisco Router Web Setup. Please wait...

Добавлено: 27-08-2013 19:08:34

Уважаемый Crash а нет ли у Вас мануалов для таких чайников как я по сискам?

8

Re: Помогите настроить CISCO SOHO 97

мануалы у меня те что на сайте cisco в основном.

9

Re: Помогите настроить CISCO SOHO 97

crash пишет:

мануалы у меня те что на сайте cisco в основном.

Вот опять, почему после реболта не могу зайти? Даже не пингует((((

10

Re: Помогите настроить CISCO SOHO 97

write memory делали?

11

Re: Помогите настроить CISCO SOHO 97

crash пишет:

write memory делали?

да, команду #wr mem

12

Re: Помогите настроить CISCO SOHO 97

sh ver покажите

13

Re: Помогите настроить CISCO SOHO 97

crash пишет:

sh ver покажите

Router#sh ver
Cisco IOS Software, SOHO97 Software (SOHO97-K9OY1-M), Version 12.3(8)YG3, RELEASE SOFTWARE (fc1)
Synched to technology version 12.3(10.3)T2
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Tue 20-Sep-05 04:55 by ealyon

ROM: System Bootstrap, Version 12.2(11r)YV3, RELEASE SOFTWARE (fc2)
ROM: Cisco IOS Software, SOHO97 Software (SOHO97-K9OY1-M), Version 12.3(8)YG3, RELEASE SOFTWARE (fc1)

Router uptime is 0 minutes
System returned to ROM by power-on
System image file is "flash:soho97-k9oy1-mz.123-8.YG3.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco SOHO97 (MPC857DSL) processor (revision 0x500) with 58983K/6553K bytes of memory.
Processor board ID FCZ100814VT (3318797041), with hardware revision 401D
CPU rev number 7
1 Ethernet interface
1 ATM interface
128K bytes of NVRAM.
8192K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)

Configuration register is 0x2142

14

Re: Помогите настроить CISCO SOHO 97

сделай так

copy startup running
conf t
config-register 0x2102
exit
wr mem

посмотри sh run, должны быть твои настройки. Если есть то перегрузи, должно нормально перегрузиться. Если нет, то снова надо будет настроить адреса и логин

15

Re: Помогите настроить CISCO SOHO 97

crash пишет:

сделай так

copy startup running
conf t
config-register 0x2102
exit
wr mem

посмотри sh run, должны быть твои настройки. Если есть то перегрузи, должно нормально перегрузиться. Если нет, то снова надо будет настроить адреса и логин

Crash спасибо большое. Все заработало. По возможности сюда же буду писать о проблеммах настройки адсл. Надеюсь поможете!

16

Re: Помогите настроить CISCO SOHO 97

пиши, постараюсь помочь, если смогу

17

Re: Помогите настроить CISCO SOHO 97

Верхотурье, это Урал?

18

Re: Помогите настроить CISCO SOHO 97

Alexander пишет:

Верхотурье, это Урал?

Да, Урал, Свердловская область!

19

Re: Помогите настроить CISCO SOHO 97

Почти земляки! Бываю иногда в Краснотурьинске.
smile

20

Re: Помогите настроить CISCO SOHO 97

Столкнулся с аналогичной проблемой - eth0 настроил, но не могу попасть в WEB. Помоги плиз!!!

21

Re: Помогите настроить CISCO SOHO 97

SOHO#show run
Building configuration...

Current configuration : 939 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SOHO
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxx
enable password xxx
!
ip subnet-zero
no ip routing
!
!
ip name-server 85.28.195.130
ip name-server 85.28.195.129
no aaa new-model
!
!
username admin privilege 15 secret 5 xxx
!
!
no crypto isakmp ccm
!
!
!
interface Ethernet0
ip address 192.168.10.1 255.255.255.0
no ip route-cache
hold-queue 100 out
!
interface ATM0
no ip address
no ip route-cache
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
ip classless
ip http server
ip http authentication local
no ip http secure-server
!
!
snmp-server community kdo RO
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password xxx
login local
!
scheduler max-task-time 5000
end

Добавлено: 23-09-2015 16:37:38

SOHO>sh ver
Cisco IOS Software, SOHO97 Software (SOHO97-K9OY1-M), Version 12.3(11)T10, RELEASE SOFTWARE (fc4)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Sat 04-Mar-06 10:55 by dchih

ROM: System Bootstrap, Version 12.2(11r)YV1, RELEASE SOFTWARE (fc1)

SOHO uptime is 36 minutes
System returned to ROM by power-on
System image file is "flash:soho97-k9oy1-mz.123-11.T10.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco SOHO97 (MPC857DSL) processor (revision 0x401) with 29492K/3276K bytes of memory.
Processor board ID FCZ091643DB (1359048073), with hardware revision 0000
CPU rev number 7
1 Ethernet interface
1 ATM interface
128K bytes of NVRAM.
8192K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)

Configuration register is 0x2102

22

Re: Помогите настроить CISCO SOHO 97

а каким образом вы подключены к провайдеру?

23 (24-09-2015 04:53:14 отредактировано Kamchadal)

Re: Помогите настроить CISCO SOHO 97

crash пишет:

а каким образом вы подключены к провайдеру?

К провайдеру пока никак не подключен, интерфейс ATM0 пока не настраивался. Подключение будет через ADSL. Минимально было сделано: через терминал настроен интерфейс Eth0, и после этих настроек пытаюсь подключиться через web. Роутер пингуется, при подключении ввожу логин и пароль и потом идет попытка загрузки веб и дальше ничего не происходит, пишет ожидайте...
Пробовал также подключаться через Cisco SDM, но результат такой же. Не знаю уже куда дальше копать. Для меня после первичных настроек подключение через веб было бы показателем верности настроек и работоспособности устройства. Что можно сделать и что проверить?
PS
По данным, известным мне, устройство ранее работало, потом попало в руки админа, который, по его словам, "обнулил" роутер. Как он это сделал и что имеется ввиду он и сам сказать уже не может (давно было дело).

24

Re: Помогите настроить CISCO SOHO 97

я думал у вас web не открывается это сайты. Вот через web на cisco вы ничего хорошего не увидите, возможно что-то в SDM получше. Хотя с SOHO не работал. А так скорее всего у вас нет html страниц на роутере. Покажите вывод

dir flash:

25

Re: Помогите настроить CISCO SOHO 97

Directory of flash:/

    1  -rw-     6183144                    <no date>  soho97-k9oy1-mz.123-11.T10.bin

8126460 bytes total (1943252 bytes free)