Перейти к содержимому раздела

Форум системного администратора FreeBSD, Linux, Unix, Windows.

Обсуждение железа, сетевых технологий, програмных комплексов и языков программирования.

Вы не вошли. Пожалуйста, войдите или зарегистрируйтесь.


Добавление ответа

Добавление ответа

Напишите и отправьте новый ответ

Вы можете использовать: BBCode Изображения Смайлики

Все поля, выделенные полужирным начертанием, должны быть заполнены.

Важная информация для гостей




Обязательно к заполнению

Обзор темы (новые сверху)

9

portupgrade но есть нюадс, нельзя ничего ковырять руками, тогда пройдет хорошо...

8

McTracher пишет:

У меня точно такая же проблема! Нашли выход из этой ситуаций??? Порты попробовал обновить, не помогло(((

Обновление портов, это ещё не всё,
надо обновить, всё что стоит.

7

У меня точно такая же проблема! Нашли выход из этой ситуаций??? Порты попробовал обновить, не помогло(((

6

может правился Makefile ?
По идее обновите порты. Проблем не должно быть если порты оригинальные.

5

Что-то я не совсем понимаю. Апач у меня стоит 13
>># httpd -v
Server version: Apache/1.3.41 (Unix)
Server built:   Oct 20 2008 01:43:35
Вот что выдает make search
>># make search name=mod_security
Port:   mod_security-1.9.4
Path:   /usr/ports/www/mod_security
Info:   An intrusion detection and prevention engine
Maint:  ale@FreeBSD.org
B-deps: apache-1.3.39_2 expat-2.0.0_1 perl-5.8.8_1
R-deps: apache-1.3.39_2 expat-2.0.0_1 perl-5.8.8_1
WWW:    http://www.modsecurity.org/

Port:   mod_security2-2.1.3
Path:   /usr/ports/www/mod_security2
Info:   An intrusion detection and prevention engine
Maint:  araujo@FreeBSD.org
B-deps: apache-2.0.61_2 expat-2.0.0_1 libiconv-1.11_1 perl-5.8.8_1
R-deps: apache-2.0.61_2 expat-2.0.0_1 libiconv-1.11_1 perl-5.8.8_1
WWW:    http://www.modsecurity.org/

Port:   www/mod_security2
Moved:  www/mod_security21
Date:   2008-06-22
Reason: Moved to www/mod_security2.
Исходя из этого, в порте /usr/ports/www/mod_security лежит mod_security-1.9.4 для первого апача. Ставлю я именно его, но при установке стягивается почемуто мод для 2 апача.
make install
===>  mod_security-2.5.5_2 : Error from bsd.apache.mk. apache13 is installed (or APACHE_PORT is defined) and port requires 2.0+.
*** Error code 1
Где загвостка?

4

Alexander

Ghost123 пишет:

apache13 is installed

Добавлено спустя       48 секунд:
а мод_секьюрити ставится 2 версии похоже

Ghost123 пишет:

mod_security-2.5.5_2

3

mysql# cd /usr/ports
mysql# make search name=mod_security
Port:   mod_security-1.9.4
Path:   /usr/ports/www/mod_security
Info:   An intrusion detection and prevention engine
Maint:  ale@FreeBSD.org
B-deps: apache-1.3.39_2 expat-2.0.0_1 perl-5.8.8_1
R-deps: apache-1.3.39_2 expat-2.0.0_1 perl-5.8.8_1
WWW:    http://www.modsecurity.org/

Port:   mod_security2-2.1.3
Path:   /usr/ports/www/mod_security2
Info:   An intrusion detection and prevention engine
Maint:  araujo@FreeBSD.org
B-deps: apache-2.0.61_2 expat-2.0.0_1 libiconv-1.11_1 perl-5.8.8_1
R-deps: apache-2.0.61_2 expat-2.0.0_1 libiconv-1.11_1 perl-5.8.8_1
WWW:    http://www.modsecurity.org/

Port:   www/mod_security2
Moved:  www/mod_security21
Date:   2008-06-22
Reason: Moved to www/mod_security2.

Я так подумал, видимо у него и стоит 2-я апаче. Надо идти в порт для 2-й версии скорее всего.

2

похоже что порт хочет апаче 2+, а у вас стоит 1.3. Попробуйте сначала проапдейтить апач.

1

Это снова я wink На сей раз не ставится mod_security. Гугль по этому поводу молчит. В чем трабла?
make install
===>  mod_security-2.5.5_2 : Error from bsd.apache.mk. apache13 is installed (or APACHE_PORT is defined) and port requires 2.0+.
*** Error code 1

Stop in /usr/ports/www/mod_security.



Currently installed 13 official extensions. Copyright © 2003–2010 PunBB.